Toyota 120 Platforms Forum
Google only search Toyota120

Go Back   Toyota 120 Platforms Forum > General Tech > 4th Gen 4Runner & Hilux Surf

Reply
Thread Tools Display Modes
Unread 02-26-2016, 12:25 PM   #1
the_josh
East Bay Adventurer
 
the_josh's Avatar
 
Join Date: Feb 2006
Location: East Bay, California
Posts: 4,130
Default P0306 Error Code Plus Consistent Misfire

Earlier this week on Monday my battery was dead on the 4runner so I had to jump it, I let it warm up for awhile and then I drove it to my buddies house to help him work on his truck. I was there for about 5 hours and when I hopped in my truck and started it up I felt a misfire and I shifted the truck into reverse and it kept misfiring while backing up and the CEL was flashing. Once I shifted back into drive it was fine and drove home with no issues. It sat the rest of the week until today when I started it up with no issue and no misfires (hooked up to a trickle charge all week) I pulled the code and got p0306 cylinder 6 misfire.

Here is what I know:
Original injectors
Engine has about 90k on it
The last time I changed the spark plugs if memory serves me right was when I installed the engine at 30k back in 2009
Original coil packs.

I'm thinking of starting with the spark plugs and going from there. Anyone else have any suggestions?

Thanks

Sent from my SM-N920T using Tapatalk
__________________
2004 4Runner Sport // Curried & ARB Locked D60 4.88's // A Bunch of other Doo-Dads
Best Selling Author of "Tiny House Basics: Living the Good Life in Small Spaces"
bit.ly/THBBook
the_josh is offline   Reply With Quote
Unread 02-26-2016, 01:29 PM   #2
medic83
Solid Axle Beast
 
medic83's Avatar
 
Join Date: Feb 2008
Location: San Francisco Bay Area
Posts: 2,796
Default

Plugs....coil packs...injectors....run injector cleaner as well
__________________
05 SE 4x4 V6 Black
medic83 is offline   Reply With Quote
Unread 02-26-2016, 06:14 PM   #3
BlackWorksInc
Senior Driver
 
BlackWorksInc's Avatar
 
Join Date: Mar 2011
Location: Bend, OR
Posts: 700
Default

Hmm... so thee misfire isn't there right now? Just that one or two times before?

What year/engine is your 4Runner again?

I'd start with plugs and regular maintenance items if it hasn't been done in a while, fuel injector cleaner wouldn't hurt either. I'd also clean the throttle body if it hasn't been done in a while and then disconnect the battery for a good 10min and let the vehicle relearn idle after you do all that and see if it helps. Simple stuff first.
__________________
BlackWorksInc is offline   Reply With Quote
Unread 02-26-2016, 07:23 PM   #4
eskimochaos
Driver
 
Join Date: Aug 2008
Location: The Moon
Posts: 193
Default

Headgasket....
eskimochaos is offline   Reply With Quote
Unread 02-26-2016, 08:10 PM   #5
BlackWorksInc
Senior Driver
 
BlackWorksInc's Avatar
 
Join Date: Mar 2011
Location: Bend, OR
Posts: 700
Default

Quote:
Originally Posted by eskimochaos View Post
Headgasket....
I'm starting to wonder that, but simple **** first.
__________________
BlackWorksInc is offline   Reply With Quote
Unread 02-27-2016, 11:51 AM   #6
bulldog
Admin
 
bulldog's Avatar
 
Join Date: May 2005
Location: Walnut Creek, CA
Posts: 12,313
Default

Do the plugs and make sure the battery has a proper charge. May just be the plugs are not 100% and with a bit lower voltage it misses a bit.

The V6 plugs are supposed to be changed every 30k miles anyway.
__________________
andries
K9BDG

2019 Low Rider
bulldog is offline   Reply With Quote
Unread 02-27-2016, 01:28 PM   #7
Thrasher
Driver
 
Thrasher's Avatar
 
Join Date: Sep 2009
Location: SF Bay Area
Posts: 163
Default

Ive been having P0306 on and off for a few months. It will happen from cold starts, for the first 10 or so seconds, for a week or so, then run fine for a month no problems, then repeat. I had it in the mechanic in October when it first started and he said he really really didnt think it was the headgasket. I replaced the plugs with toyota plugs last summer, but we tried swapping plugs and coil packs around, as well as swapping injectors and running injector cleaner pretty regularly for a few weeks. It stayed on cyl 6. Mine is a 05 V6 with 156k.
__________________
Aaron
White 05 SR5 4x4
I need more money!

Last edited by Thrasher; 02-27-2016 at 01:31 PM.
Thrasher is offline   Reply With Quote
Unread 02-27-2016, 10:44 PM   #8
BlackWorksInc
Senior Driver
 
BlackWorksInc's Avatar
 
Join Date: Mar 2011
Location: Bend, OR
Posts: 700
Default

Quote:
Originally Posted by Thrasher View Post
Ive been having P0306 on and off for a few months. It will happen from cold starts, for the first 10 or so seconds, for a week or so, then run fine for a month no problems, then repeat. I had it in the mechanic in October when it first started and he said he really really didnt think it was the headgasket. I replaced the plugs with toyota plugs last summer, but we tried swapping plugs and coil packs around, as well as swapping injectors and running injector cleaner pretty regularly for a few weeks. It stayed on cyl 6. Mine is a 05 V6 with 156k.
Have a leak down test done.
__________________
BlackWorksInc is offline   Reply With Quote
Unread 02-28-2016, 04:21 PM   #9
Wishbone
Senior Driver
 
Wishbone's Avatar
 
Join Date: Jan 2011
Location: CO
Posts: 947
Default

Almost guaranteed HG on both accounts.
__________________
04 V6 SR5 King/Dirt King

Wishbone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Misfire, Cylinder 6 Alex123456 4th Gen 4Runner & Hilux Surf 63 06-11-2013 10:23 PM


All times are GMT -7. The time now is 06:22 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2005-2013 Toyota120.com