Toyota 120 Platforms Forum
Google only search Toyota120

Go Back   Toyota 120 Platforms Forum > Shared tech > Maintenance

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Unread 06-27-2014, 07:41 AM   #1
HOJeepster
Driver
 
HOJeepster's Avatar
 
Join Date: Aug 2009
Location: CO
Posts: 447
Default Alignment Issues: Bend Rear Links?

After installing the new 275/70/18 Duratracs, it seems Discount Tire can't get rid of this wobble/shaking I get. I've had them rebalance twice now, and the issue still exists. They believe that because I offroad, some of the weights may have come off. Although this is possible, I don't think it's the cause.

Is it possible that having slightly bent lower rear links may have caused my rear alignment to be out of whack? Or should I stick with the theory that the tires are just out of balance? I'm just wondering if new metal tech rear links are on the horizon.

Thanks.
__________________
2006 T4R V8 |
HOJeepster is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Extended rear sway bar links install 4mudder Suspension and Tires 37 07-20-2018 10:43 AM
Metal Tech Offset Rear Lower Links Install cmiller Suspension and Tires 37 03-31-2016 01:47 PM
Got P0430 code on my 04 V6 SR5 T4R superdjl 4th Gen 4Runner & Hilux Surf 51 10-31-2015 01:33 PM
Custom(ish) Extended Rear Sway Bar Links Write-up nathana92 Suspension and Tires 70 07-03-2015 02:49 PM
New Forerunner Fab Custom Rear Links the_josh For Sale Members 24 12-06-2014 01:49 AM


All times are GMT -7. The time now is 03:40 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2005-2013 Toyota120.com