Toyota 120 Platforms Forum
Google only search Toyota120

Go Back   Toyota 120 Platforms Forum > Shared tech > Audio, Electronics and Electrical

Reply
Thread Tools Display Modes
Unread 02-01-2010, 12:58 PM   #1
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default ScanGaugeII Xgauge codes for 4Runner

I recently purchased a ScanGaugeII and starting messing around with the Xgauge codes to see what other elements I could mine from the OBDII system. This post is where we could consolidate all the working Xgauge codes that we know of for the 4runner into one place.

These are codes I've tested as working on my truck, your results may vary.

Working codes (firmware 4.06)

Atmospheric Pressure (Psi) - shows to the nearest PSI (may be mutually exclusive of the Altitude reading, i.e. you can only display either Psi or Alt at one time)
TXD: 07E02133
RXF: 04610533
RXD: 2808
MTH: 000A00450000
NAM: Psi

Altitude Gauge (Feet) - Very rough elevation based off atmospheric pressure, shows approx. elevation at set 274' intervals (may be mutually exclusive of the Psi reading)
TXD: 07E02133
RXF: 04610533
RXD: 2808
MTH: FEEE00016B08
NAM: Alt

Horsepower - brake horse power rough calculation based on engine size and operating parameters
TXD: 00
RXF: 400080000000
RXD: 0000
MTH: 000A00170000
NAM: HPR

Transmission temperature
TXD: 07E021D9
RXF: 032180000000
RXD: 2810
MTH: 00070064FE70
NAM: TFT

Distance to empty (a built-in feature accessible elsewhere in the unit, but nice to display as a Xgauge)
TXD: 44
RXF: 800000000000
RXD: 0000
MTH: 000000000000
NAM: DtE

Codes that DO NOT work

- All transmission temp. listings in the Xgauge pdf (Ford PWM, Ford CAN, GM VPW, GM CANSF, VW ISO)

- Tranny temp reported to work for 3rd gen 4Runners: TXD: 686AF101B4, RXF: 044105B40000, RXD: 2808, MTH: 00090005FFD8, NAM: TFT

- A/F ratio: TXD: 07E02144, RXF: 04614544, RXD: 2808, MTH: 05BE00800000, NAM: A/F

- A/F ratio: TXD: 07E02144, RXF: 04614544, RXD: 2808, MTH: 006400800000, NAM: AFL
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com

Last edited by Mikestang; 11-29-2011 at 03:48 PM.
Mikestang is offline   Reply With Quote
Unread 02-01-2010, 01:02 PM   #2
bulldog
Admin
 
bulldog's Avatar
 
Join Date: May 2005
Location: Walnut Creek, CA
Posts: 12,314
Default

Very interesting, keep us posted.
__________________
andries
K9BDG

2019 Low Rider
bulldog is offline   Reply With Quote
Unread 02-01-2010, 01:25 PM   #3
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default

Deleted, old info.
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com

Last edited by Mikestang; 11-29-2011 at 03:37 PM.
Mikestang is offline   Reply With Quote
Unread 02-01-2010, 01:54 PM   #4
AlexJet
Old Timer
 
AlexJet's Avatar
 
Join Date: Apr 2006
Location: Toronto, ON
Posts: 4,060
Default

Very Interested. I was thinking of try XGauge, but didn't had a time to play. Thank you Mike, keep us updated.
__________________
'05 4Runner V6 Limited --- Custom 5" LT; 35"; ARB, CBI; Snorkel; etc...
'16 4Runner Limited --- Daily Driver; 3"; 33", Snorkel
'74 FJ40 --- 5"; 35", Snorkel, etc...
'09 Custom Expedition Trailer --- 35"
AlexJet is offline   Reply With Quote
Unread 02-07-2010, 03:00 PM   #5
softg
Rookie
 
softg's Avatar
 
Join Date: Jan 2010
Location: denver
Posts: 41
Default

so, whats this, in simple people terms?
__________________
2004 limited with all the factory goodies and an impending off-road mod filled christmas
softg is offline   Reply With Quote
Unread 11-01-2011, 10:19 PM   #6
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default

Well, I was excited for a second. The ScanGauge people finally posted XGauge codes for tranny temp for Toyotas that use CANSF protocol, which our 4Runners (2005+) are supposed to use.

Quote:
http://www.scangauge.com/support/toyota-specific/
Toyota Specific

The following are XGauge codes for Toyota vehicles.
General Toyota (CANSF)
GAUGE TXD RXF RXD MTH NAME Notes
Transmission Temperature 07E021D9 032180000000 2810 00070064FE70 TFT Degrees F
Note: The above code will only work on Toyota’s that use the CANSF protocol which was typically used by Toyota starting in the 2005 model year. Our list of which Toyota vehicles support the CANSF protocol can be found here.
I tried it and it didn't work, bummer. I also tried a variation I saw on a Tundra forum, but I think they just made typos when they copied it down.
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com

Last edited by Mikestang; 11-01-2011 at 10:53 PM.
Mikestang is offline   Reply With Quote
Unread 11-01-2011, 10:23 PM   #7
java230
Old Timer
 
java230's Avatar
 
Join Date: Mar 2009
Location: Seattle, WA
Posts: 2,098
Default

has anyone gotten tranny temp to work in the early 4th gens? ones that dont use CANSF code?
__________________
03 V6, OME, 265/70/17 Duratrac's, all-pro spacers, Rola rack, Perkins Front bumper, DIY drawers, 7" HID driving lights, M8000, CB
java230 is offline   Reply With Quote
Unread 11-01-2011, 10:54 PM   #8
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default

No, the only reported success I've found has been in 3rd gen.
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com
Mikestang is offline   Reply With Quote
Unread 11-01-2011, 11:16 PM   #9
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default

I checked and my firmware is pretty old (v3.17). I might send it in to be updated and see if that activates the tranny temp.
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com
Mikestang is offline   Reply With Quote
Unread 11-02-2011, 09:00 AM   #10
Ludedude
Super Moderator
 
Ludedude's Avatar
 
Join Date: Jul 2009
Location: DM26LB
Posts: 1,601
Default

Quote:
Originally Posted by Mikestang View Post
I checked and my firmware is pretty old (v3.17). I might send it in to be updated and see if that activates the tranny temp.
Keep us updated on that.
__________________
'20 Army Green 4Runner TRD PRO
'16 Quicksand Tundra TRD PRO Gone but not forgotten
'08 Salsa Red Pearl 4x4Runner SE V6:
Gone but not forgotten
Ludedude is offline   Reply With Quote
Unread 11-02-2011, 10:13 AM   #11
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default

I got a response from the makers of ScanGauge, looks promising, I'll be sending in my unit for the update shortly and I'll report back if the tranny temp function works (although I'll have nothing really to base it on other than what temp I think the tranny should be at during normal driving conditions).

Quote:
Hi Mike,

We received your comment via our website and I just wanted to answer your question as to whether an update to the latest firmware would allow you to view TFT on your 4-Runner. An upgrade should solve the problem. Our latest update added some key features to the XGauge system that allowed it to get values like TFT from Toyota. We’ve been testing this code a lot on the Tacoma World forums, and we did upgrades for some of there members which resulted in them being able to view transmission temperature with the XGauge listed on our site when they previously couldn’t.

Let me know if you have any further questions.

Regards,

James DeLong
Linear Logic LLC
Operations Manager
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com
Mikestang is offline   Reply With Quote
Unread 11-02-2011, 10:55 AM   #12
Ludedude
Super Moderator
 
Ludedude's Avatar
 
Join Date: Jul 2009
Location: DM26LB
Posts: 1,601
Default

nice.
__________________
'20 Army Green 4Runner TRD PRO
'16 Quicksand Tundra TRD PRO Gone but not forgotten
'08 Salsa Red Pearl 4x4Runner SE V6:
Gone but not forgotten
Ludedude is offline   Reply With Quote
Unread 11-02-2011, 06:20 PM   #13
Zstampe
Driver
 
Zstampe's Avatar
 
Join Date: Oct 2010
Posts: 185
Default

My tranny temp works great on my 06!

Edit: I set it up the other day using the info provided on the scangauge website
__________________
2006 SR5 4x4 OME 885/895, 1" Toytec Body lift, Bilsteins, BajaRack!!!, 285/70 17 Terra Grapplers, HIDs, Full weathertechs, recovery gear, CB, Pioneer DVD headunit etc etc

My hoopty: http://www.toyota120.com/forum/showthread.php?t=23065

"You got no legs leuitenant Dan!!!!!!"
Zstampe is offline   Reply With Quote
Unread 11-02-2011, 07:57 PM   #14
Teotwaki
Adventurer
 
Teotwaki's Avatar
 
Join Date: May 2006
Posts: 2,714
Default

lurking.....
__________________
Jim
My Adventure Blog: "Sun To The North"
'05 SR5 4WD V6
HQ sliders, OW Suspension, LT265/75/R16C Duratracs, rear diff. breather, ScanGauge II, Garmin 276C, Engel 45 fridge, All-Pro LCAs, TC A-Arm Skids, dual batteries, Downey skid plate, Cyclone pre-filter, ARB Compressor & Rear Locker!! Offroad Trailer
Photos http://www.toyota120.com/forum/showthread.php?t=1237
Teotwaki is offline   Reply With Quote
Unread 11-02-2011, 09:47 PM   #15
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default

Quote:
Originally Posted by Zstampe View Post
My tranny temp works great on my 06!

Edit: I set it up the other day using the info provided on the scangauge website
Great to hear. Can you post up your firmware version please?



..........Firmware Check - Post 4.0 ....................................... Firmware Check - pre 4.0

And what the hell is that quote in your sig?
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com

Last edited by Mikestang; 11-02-2011 at 09:50 PM.
Mikestang is offline   Reply With Quote
Unread 11-03-2011, 08:04 AM   #16
Zstampe
Driver
 
Zstampe's Avatar
 
Join Date: Oct 2010
Posts: 185
Default

Quote:
Originally Posted by Mikestang View Post
Great to hear. Can you post up your firmware version please?



..........Firmware Check - Post 4.0 ....................................... Firmware Check - pre 4.0

And what the hell is that quote in your sig?
Yep, I'll check it this evening. Out doing fire inspections at work today......FML.

Ha! The quote is just a funny quote a buddy of mine said one day. Dudes a character.
__________________
2006 SR5 4x4 OME 885/895, 1" Toytec Body lift, Bilsteins, BajaRack!!!, 285/70 17 Terra Grapplers, HIDs, Full weathertechs, recovery gear, CB, Pioneer DVD headunit etc etc

My hoopty: http://www.toyota120.com/forum/showthread.php?t=23065

"You got no legs leuitenant Dan!!!!!!"
Zstampe is offline   Reply With Quote
Unread 11-04-2011, 07:02 AM   #17
Zstampe
Driver
 
Zstampe's Avatar
 
Join Date: Oct 2010
Posts: 185
Default

4.02 is my version.
__________________
2006 SR5 4x4 OME 885/895, 1" Toytec Body lift, Bilsteins, BajaRack!!!, 285/70 17 Terra Grapplers, HIDs, Full weathertechs, recovery gear, CB, Pioneer DVD headunit etc etc

My hoopty: http://www.toyota120.com/forum/showthread.php?t=23065

"You got no legs leuitenant Dan!!!!!!"
Zstampe is offline   Reply With Quote
Unread 11-04-2011, 11:13 AM   #18
Mikestang
Don't follow this guy
 
Mikestang's Avatar
 
Join Date: Jun 2006
Location: The wild wild west
Posts: 4,471
Default

Awesome, thanks! I'm going to send mine in next week for the firmware update. I'm kinda bummed that 1) they charge you $25 for the update, and 2) you can't pay and d/l immediately, you have to send the unit into them.
__________________
'07 Ltd 4Runner v8 4x4 - Midland 75-822 + Wilson 5000, Garmin 276c, Magnaflow catback, Kurtfab front diff brace, 265/70/17 Goodyear ATA on Robby Gordon Signatures, Spidertrax, 3/4" BL, BajaRack, 2wd sway, Icon front, Overland Warehouse rear, Kurtfab v2.1 LCAs, MedicLinks, Slee SS lines, BB skids, Demello sliders & LCA ramps, All-Pro diff guard, TC full gusseted front, SW bumper
www.mikestang.com
Mikestang is offline   Reply With Quote
Unread 11-04-2011, 02:36 PM   #19
prjeff46
Buckeye Runner
 
prjeff46's Avatar
 
Join Date: Sep 2008
Location: Fredneck, MD
Posts: 606
Default

Quote:
Originally Posted by Mikestang View Post
And what the hell is that quote in your sig?
Maybe I am being real obvious but it's from Forest Gump.
__________________
Jeff
Build Thread
2004 v8 SE- Duratrac 33's-OW 2.5 front/OME rear-SW front bumper-Budbuilt-Engo 10K w/synthetic line- Lightforce 170's- LR UCA's-Spidertrax- Kurtfab Diff Bracket-4xInnovations sliders-1/2" body lift-JAMFab dual swingout bumper
prjeff46 is offline   Reply With Quote
Unread 11-04-2011, 03:16 PM   #20
Zstampe
Driver
 
Zstampe's Avatar
 
Join Date: Oct 2010
Posts: 185
Default

Quote:
Originally Posted by Mikestang View Post
Awesome, thanks! I'm going to send mine in next week for the firmware update. I'm kinda bummed that 1) they charge you $25 for the update, and 2) you can't pay and d/l immediately, you have to send the unit into them.
What? That's dumb! Good luck man! Let us know how it turns out. Tranny temp is a huge plus.
__________________
2006 SR5 4x4 OME 885/895, 1" Toytec Body lift, Bilsteins, BajaRack!!!, 285/70 17 Terra Grapplers, HIDs, Full weathertechs, recovery gear, CB, Pioneer DVD headunit etc etc

My hoopty: http://www.toyota120.com/forum/showthread.php?t=23065

"You got no legs leuitenant Dan!!!!!!"
Zstampe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -7. The time now is 06:23 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2005-2013 Toyota120.com