Toyota 120 Platforms Forum
Google only search Toyota120

Go Back   Toyota 120 Platforms Forum > General Tech > 4th Gen 4Runner & Hilux Surf

Reply
Thread Tools Display Modes
Unread 09-22-2018, 12:29 PM   #1
matt640h
Rookie
 
Join Date: Nov 2017
Posts: 9
Default Rear window help please

If I disconnect the battery or the control modules in the rear hatch, the rear window will roll up and down properly for a couple of days. Then it quits working again. Rear wiper isn't working either but I haven't been paying attention to see if it works again after the "reboot". Rear washer and latch motor work all the time.

It seems as if a "reboot" briefly cures the problem and then in comes back.

Any similar experiences or recommendations on repairs?
matt640h is offline   Reply With Quote
Unread 09-24-2018, 07:07 AM   #2
bulldog
Admin
 
bulldog's Avatar
 
Join Date: May 2005
Location: Morgan Hill, CA
Posts: 12,283
Default

Does it not work at all till you disconnect power, or does it roll up and down but just not all the way automatically?
__________________
andries
K9BDG

03 pavement princess
06 toaster
bulldog is offline   Reply With Quote
Unread 09-24-2018, 03:19 PM   #3
matt640h
Rookie
 
Join Date: Nov 2017
Posts: 9
Default

Doesn’t work at all until reboot.

Tried resetting with key in the hatch. Tried resetting with dash buttons. Rear wiper is in it’s cradle. Rear window appears to be all the way up.

Last edited by matt640h; 09-24-2018 at 03:24 PM.
matt640h is offline   Reply With Quote
Unread 09-24-2018, 03:40 PM   #4
bulldog
Admin
 
bulldog's Avatar
 
Join Date: May 2005
Location: Morgan Hill, CA
Posts: 12,283
Default

I'm wondering if it is an issue with the sensor that indicates the rear hatch is closed. What happens if you open/close the hatch after it stops working?
__________________
andries
K9BDG

03 pavement princess
06 toaster
bulldog is offline   Reply With Quote
Unread 09-28-2018, 08:38 AM   #5
matt640h
Rookie
 
Join Date: Nov 2017
Posts: 9
Default

So I tried that and no change. The hatch switch appears to be working properly, when I open the hatch I see the dash light come on.

On another note, I tried the reboot again and it didn’t temporarily fix it this time but it has in the past.
matt640h is offline   Reply With Quote
Unread 10-01-2018, 06:46 AM   #6
tigerwong58
Rock Ninja
 
tigerwong58's Avatar
 
Join Date: May 2009
Location: Kansas City, MO
Posts: 362
Default

try closing it with the key in the rear hatch and open, top to bottom, that usually resets it. If it thinks the rear window is open the rear wiper will not work. The process is called initializing.
tigerwong58 is offline   Reply With Quote
Unread 10-05-2018, 06:11 AM   #7
Darklight
Old Timer
 
Darklight's Avatar
 
Join Date: May 2010
Location: Charlotte,NC
Posts: 1,751
Default

If Initializing process doesn't do it, it might be some sort of short. Maybe a fuse or relay going out.
__________________
2008 Black 4X4Runner SR5 V6, Total Chaos Race series 2" plus kit, King 700 lbs LT coilovers & MetalTech stage 5 LT rear, 315/75R16 KM2, Strike 6 16x8.5 -6 wheels , Demello offroad 3 hoop, 4X4Labs rear, ATO, RCI ,BudBuilt, Stubbs sliders, 4Crawler B/L 3/4", DynoMax , K&N , Speski barrier, sPOD, ARB CKM12, ARB locker front/rear 4.56 gears WMW roof rack
Darklight's Build
Darklight is offline   Reply With Quote
Unread 10-14-2018, 04:08 PM   #8
matt640h
Rookie
 
Join Date: Nov 2017
Posts: 9
Default

So initialization doesn't help. It seems rebooting it solves the problem for a short period of time and then it stops working. Problem is constant, not intermittent. Which relay(s) control the back window? Does the control box in the rear hatch control it at all?
matt640h is offline   Reply With Quote
Unread 10-15-2018, 12:16 PM   #9
Darklight
Old Timer
 
Darklight's Avatar
 
Join Date: May 2010
Location: Charlotte,NC
Posts: 1,751
Default

Check out the wire diagram
http://www.toyota120.com/forum/showthread.php?t=2772

Almost sounds like the motor is dying on the window. Try the fuse and relay first though!
__________________
2008 Black 4X4Runner SR5 V6, Total Chaos Race series 2" plus kit, King 700 lbs LT coilovers & MetalTech stage 5 LT rear, 315/75R16 KM2, Strike 6 16x8.5 -6 wheels , Demello offroad 3 hoop, 4X4Labs rear, ATO, RCI ,BudBuilt, Stubbs sliders, 4Crawler B/L 3/4", DynoMax , K&N , Speski barrier, sPOD, ARB CKM12, ARB locker front/rear 4.56 gears WMW roof rack
Darklight's Build
Darklight is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got P0430 code on my 04 V6 SR5 T4R superdjl 4th Gen 4Runner & Hilux Surf 51 10-31-2015 01:33 PM
Rear hatch window issues trdmedic 4th Gen 4Runner & Hilux Surf 4 11-28-2011 11:27 PM
Rear Window Not Working with Key java230 Audio, Electronics and Electrical 12 10-14-2009 08:52 PM
Rear window up function on key fob expat Audio, Electronics and Electrical 9 02-16-2009 06:57 PM


All times are GMT -7. The time now is 04:35 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2005-2013 Toyota120.com