Toyota 120 Platforms Forum
Google only search Toyota120

Go Back   Toyota 120 Platforms Forum > General Tech > 4th Gen 4Runner & Hilux Surf

Reply
 
Thread Tools Display Modes
Old 05-22-2011, 01:05 PM   #1
Sunnyc123abc
Rookie
 
Join Date: Nov 2010
Posts: 2
Default 4lo& center diff lock light flashing on startup

Hi, I have a 2004 4runner v8 4x4. Almost every time I start it up, the 4lo & center diff lock lights flash. To get them to stop flashing, I either have to keep restarting the car like 5 times, or drive a couple feet forward and restart the car. When I get the lights to not flash from start up, 4lo & the center diff lock all engage with out any problems. What do you guys think might be the problem?
Sunnyc123abc is offline   Reply With Quote
Old 05-24-2011, 12:34 PM   #2
aqua33
Driver
 
aqua33's Avatar
 
Join Date: Sep 2009
Location: Naptown, MD
Posts: 133
Default

I am having the same problem with my 2003 V6 SR5 4x4. My issues started just like yours and then escalated to the point where my trandfer case will not engage in 4wd. My original solution was to cycle through 4hi, 4lo and then lock the center diff. Now after a few weeks it appears the transfer case actuator has seized. I am looking at alternatives to haveing the dealer replace the actuator for $2500 and trying to find used complete TC to swap out. A salvaged TC woudl be a lot cheaper then a repaired TC. Right now I have been driving with the 4lo and center diff lock indicators flashing at me. My issue is cost and time. I really do not want to drop 3k to 4k to fix my rig. Hopefully your rig is not as bad as mine but this is how mine started.

Pete
__________________
2003 4Runner SR5 4x4 V6
Complete FJ Trail Team suspension mated to a ReadyLift SST 3"/2" kit, Rear Diff breather extended to gas door, Rear brake extender, FJ 17" wheels with Michelin LTX AT2 285/70/17 shoes, Rola Rack w/extension and fully welded with homemade roof brackets, No running boards.
aqua33 is offline   Reply With Quote
Old 05-24-2011, 03:36 PM   #3
Sunnyc123abc
Rookie
 
Join Date: Nov 2010
Posts: 2
Default

I started playing with the diff lock switch, took it apart cleaned it, and that seem to fix it for a day, but it came right back. Weird thing is, is that my actuators seem fine. They don't really delay when i switch them on. Maybe the cpu might be going bad.
Sunnyc123abc is offline   Reply With Quote
Old 05-24-2011, 11:50 PM   #4
bulldog
Admin
 
bulldog's Avatar
 
Join Date: May 2005
Location: Morgan Hill, CA
Posts: 11,802
Default

May be good to look at the wiring diagram to see which wires to your 4WD ECU comes form the sensors in the TC. You can then check to see if it is the sensors in the TC giving you bad info.

May also be worthwhile to borrow a 4WD ECU similar to yours and see if a swap solves the issue.
__________________
andries
K9BDG

03 pavement princess
06 toaster
bulldog is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aux lighting Information Lexwoody Audio, Electronics and Electrical 2 01-22-2010 09:02 AM
Center Diff light Lexwoody Offroad Tech 5 10-04-2009 07:12 AM
Center Diff Lock issue Teampez 4th Gen 4Runner & Hilux Surf 8 07-23-2009 09:30 PM
Center Diff Lock travistheone 4th Gen 4Runner & Hilux Surf 4 09-10-2007 11:30 PM
98 LC Diff Lock 007-FJC Off Topic Chat 6 11-21-2005 01:52 PM


Buy your Toyota120 sticker!

All times are GMT -7. The time now is 05:58 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005-2013 Toyota120.com